





























































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Blog Post - Feedback File" />
  
    <meta name="oid" content="7632691" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=a5af3c251aceaa26b0f9f29ad4ed2952" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=a5af3c251aceaa26b0f9f29ad4ed2952" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=a5af3c251aceaa26b0f9f29ad4ed2952" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=a5af3c251aceaa26b0f9f29ad4ed2952" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/styles/transmetropolitan-8-zone-custom.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Charleston City Paper RSS: Whole Site" href="http://www.charlestoncitypaper.com/charleston/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Charleston City Paper RSS: Music+Clubs Section" href="http://www.charlestoncitypaper.com/charleston/Rss.xml?oid=1072086" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Charleston City Paper RSS: Feedback File" href="http://www.charlestoncitypaper.com/charleston/Rss.xml?oid=1139567" />
      
        <link rel="alternate" type="application/rss+xml" title="Charleston City Paper RSS: Feedback File: " href="http://www.charlestoncitypaper.com/charleston/Rss.xml?category=1139567&amp;topic=oid%3A1172578" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Charleston City Paper RSS: Comments on Feedback File" href="http://www.charlestoncitypaper.com/charleston/Rss.xml?id=comments&amp;oid=1139567" />
      
        <link rel="alternate" type="application/rss+xml" title="Charleston City Paper RSS: Comments on Feedback File: " href="http://www.charlestoncitypaper.com/charleston/Rss.xml?category=1139567&amp;id=comments&amp;topic=oid%3A1172578" />
      
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=351d89de98"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=351d89de98"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("http:\/\/www.charlestoncitypaper.com\/charleston\/Profile", "http:\/\/posting.charlestoncitypaper.com\/charleston\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="261557618855-u7gug6kig67b1pfvsdlcidorjmg8nreo.apps.googleusercontent.com">
  

    
  

  
  


  <script type="text/javascript" src="http://partner.googleadservices.com/gampad/google_service.js">
  </script>

  <script type="text/javascript">
    GS_googleAddAdSenseService("ca-pub-2574871568693937");
    GS_googleEnableAllServices();
  </script>

  <script type="text/javascript">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</script>


  <script type="text/javascript">
    GA_googleFetchAds();
  </script>


<!-- Async Ads -->
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
googletag.defineSlot('/1034489/Homepage_Pencil', [975, 50], 'div-gpt-ad-pencil-homepage').addService(googletag.pubads());
googletag.defineSlot('/1034489/Billboard_Inside', [970, 250], 'div-gpt-ad-billboard-inside').addService(googletag.pubads());
googletag.defineSlot('/1034489/Billboard_Arts', [970, 250], 'div-gpt-ad-billboard-arts').addService(googletag.pubads());
googletag.defineSlot('/1034489/Billboard_Home', [970, 250], 'div-gpt-ad-billboard-home').addService(googletag.pubads());
googletag.defineSlot('/1034489/Pencil_Other', [975, 50], 'div-gpt-ad-pencil-other').addService(googletag.pubads());
googletag.defineSlot('/1034489/Other_Expanded', [970, 90], 'div-gpt-ad-other-expanded').addService(googletag.pubads());
googletag.defineSlot('/1034489/Pushdown_Collapsed', [970, 90], 'div-gpt-ad-pushdown-collapsed').addService(googletag.pubads());
googletag.defineSlot('/1034489/Pushdown_Expanded', [970, 325], 'div-gpt-ad-pushdown-expanded').addService(googletag.pubads());
googletag.defineSlot('/1034489/Full_Background_Ad', [1, 1], 'div-gpt-ad-background').addService(googletag.pubads());
googletag.defineSlot('/1034489/Food-Drink_Interstitial', [300, 250], 'div-gpt-ad-fooddrink-interstitial').addService(googletag.pubads());
googletag.defineSlot('/1034489/Sponsored_HP1', [300, 600], 'div-gpt-ad-sponsored-hp1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.pubads().setTargeting('oid', [7632691]);
    googletag.enableServices();
  });
</script>
<!-- // Async Ads -->





<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

<!-- CHARTBEAT -->

<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>

<!-- /CHARTBEAT -->












<!-- Post - 1139567 - Music+Clubs  -->
















  


  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="REVIEW: Is SoFar Sounds overhyped or nah? | Feedback File" />
  <meta name="description" content="It isn&rsquo;t chic to use a DIY ethic &mdash; it&rsquo;s utilitarian to use a DIY ethic" />
  <meta name="keywords" content="SoFar Sounds, FALINE, Brave Baby, Mechanical River, Local Bands, Local Musicians, Scene" />
  <title>REVIEW: Is SoFar Sounds overhyped or nah? | Feedback File</title>

  
  
  
    <meta name="author" content="Heath Ellison">
  

  
  
  <meta name="news_keywords" content="sofar sounds, faline, brave baby, mechanical river, local bands, local musicians, scene" />

  
  
    
  
  
    <link rel="image_src" href="https://media2.fdncms.com/charleston/imager/u/slideshow/7645236/screen_shot_2017-04-12_at_10.46.30_am.png" />
    <meta name="thumbnail" content="https://media2.fdncms.com/charleston/imager/u/slideshow/7645236/screen_shot_2017-04-12_at_10.46.30_am.png" />
  

  
    
      <link rel="canonical" href="http://www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/12/review-is-sofar-sounds-overhyped-or-nah" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="http://www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/12/review-is-sofar-sounds-overhyped-or-nah?media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="http://www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/12/review-is-sofar-sounds-overhyped-or-nah" />
    
  

  
    <meta property="fb:app_id" content="175028705897463" />
  

  
  <meta property="og:site_name" content="Charleston City Paper" />
  <meta property="og:title" content="REVIEW: Is SoFar Sounds overhyped or nah?" />
 
  
    <meta property="og:image" content="https://media2.fdncms.com/charleston/imager/u/slideshow/7645236/screen_shot_2017-04-12_at_10.46.30_am.png" />

    
    

    
    

    
      <meta property="og:image:width" content="654" />
      <meta property="og:image:height" content="589" />
    
  

  
  
    <meta property="og:description" content="It isn&rsquo;t chic to use a DIY ethic &mdash; it&rsquo;s utilitarian to use a DIY ethic" />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">7632691</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20170412122627</Attribute>
        <Attribute name="creationdate">20170411155719</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20170412111500</Attribute>
            <Attribute name="releasedate">20170412</Attribute>
            <Attribute name="releaseepoch">1492010100</Attribute>
            <Attribute name="title">REVIEW: Is SoFar Sounds overhyped or nah?</Attribute>
            <Attribute name="author">6147989</Attribute>
            <Attribute name="authorname">Heath Ellison</Attribute>
            <Attribute name="authorsortname">Ellison, Heath</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"http:\/\/www.charlestoncitypaper.com\/FeedbackFile\/archives\/2017\/04\/12\/review-is-sofar-sounds-overhyped-or-nah"
          },
          "headline": "REVIEW: Is SoFar Sounds overhyped or nah?",
          
            "description": "It’s easy to get cynical about SoFar Sounds. Reading their website, they feel like they’re purposefully channeling the most obnoxious tendencies of music fans — namely an elitist obsession with things that are secretive.",
          
          
            "image": {
              "url": "https:\/\/media2.fdncms.com\/charleston\/imager\/u\/original\/7645236\/screen_shot_2017-04-12_at_10.46.30_am.png",
              "width": 583,
              "height": 525,
              "@type": "ImageObject"
            },
          
          "datePublished": "2017-04-12T11:15:00",
          "dateModified": "2017-04-12T12:26:27",
          
            "author": {
              "name": "Heath Ellison",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Charleston City Paper",
            
              
              
              
              "logo": {
                "url": "http:\/\/www.charlestoncitypaper.com\/imager\/b\/google-amp-logo\/808579\/2f03\/chascitypaper.jpeg",
                "width": 200,
                "height": 200,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


  
  

    
    

    
    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media2.fdncms.com/charleston/imager/u/slideshow/7645236/screen_shot_2017-04-12_at_10.46.30_am.png">

    
    

    

    <meta name="twitter:site" content="@ChasCityPaper">
    <meta name="twitter:title" content="REVIEW: Is SoFar Sounds overhyped or nah?">
    <meta name="twitter:description" content="It isn&rsquo;t chic to use a DIY ethic &mdash; it&rsquo;s utilitarian to use a DIY ethic">
  
</head>





  <body id="Post" class="BlogPostFeedbackFile FeedbackFile musicclubs Transmetropolitan8Zone">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">

  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader BlogPostFeedbackFile " style="display:none">
        
        
          Switch to the <a href="http://m.charlestoncitypaper.com/FeedbackFile/archives/2017/04/12/review-is-sofar-sounds-overhyped-or-nah" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  





<div id="thintop" class="GlobalHeader BlogPostFeedbackFile ">
 
	<div id="siteSearch">
	
		<form class="prepTextForm" id="searchbox_010728361441185215229:pknwh-vjlx4" action="http://www.charlestoncitypaper.com/charleston/Search" name="searchbox_010728361441185215229:pknwh-vjlx4">
		
		<input type="hidden" name="cx" value="010728361441185215229:pknwh-vjlx4" /> <input type="hidden" name="cof" value="FORID:11" /> <input type="text" name="q"  class="searchField" /> <input type="submit" name="sa" value="" class="searchButton" /> 

		</form>
		
	</div>
        
	<ul id="socialbuttonsgroup" class="socialbuttons">

		<li><a href="http://www.charlestoncitypaper.com/charleston/twitter/page"><img src="http://www.charlestoncitypaper.com/images/home/twitter.gif" alt="Twitter" title="Twitter" border="0" width="16" height="16" /></a></li>
		<li><a href="https://www.facebook.com/charlestoncitypaper?filter=1" target="_blank"><img src="http://www.charlestoncitypaper.com/images/home/facebook.gif" alt="Facebook" title="Facebook" border="0" width="16" height="16" /></a></li>
		<li><a href="http://pinterest.com/chascitypaper" target="_blank"><img src="http://www.charlestoncitypaper.com/images/home/pinterest.gif" alt="Pinterest" title="Pinterest" border="0" width="16" height="16" /></a></li>
		<li><a href="https://foursquare.com/user/1688479" target="_blank"><img src="http://www.charlestoncitypaper.com/images/home/foursquare.gif" alt="Forusquare" title="Foursquare" border="0" width="16" height="16" /></a></li>
		<li><a href="http://www.youtube.com/user/charlestoncitypaper/videos" target="_blank"><img src="http://www.charlestoncitypaper.com/images/home/youtube.gif" alt="YouTube" title="YouTube" border="0" width="16" height="16" /></a></li>		
		<li><a href="http://charlestoncitypaper.tumblr.com/" target="_blank"><img src="http://www.charlestoncitypaper.com/images/home/tumblr.gif" alt="Tumblr" title="Tumblr" border="0" target="_blank" width="16" height="16" /></a></li>
	
	</ul> 
        
	

	<ul data-view="loggedin" style="display:none" class="membershiplinks">

		<li><strong data-label="username">username</strong>  </li>
		<li><a href="http://posting.charlestoncitypaper.com/charleston/Profile/MySettings">edit Profile</a>  </li>
		<li><a href="http://www.charlestoncitypaper.com/charleston/Logout">logout</a></li>
		
	</ul>

	<ul data-view="loggedout" style="display:none" class="membershiplinks">

		<li><a href="#LogIn">login</a>  </li>
		  
		
	</ul>
        
	<ul id="classifiedlinksgroup" class="classifiedlinks">

		<li><a href="http://exchange.charlestoncitypaper.com/sc/jobs/search">jobs</a></li>
		<li><a href="http://exchange.charlestoncitypaper.com/sc/auto/search">cars</a></li>
		<li><a href="http://exchange.charlestoncitypaper.com/sc/real-estate/search">homes</a></li>
		<li><a href="http://exchange.charlestoncitypaper.com/sc/rentals/search">rentals</a></li>
		<li><a href="http://exchange.charlestoncitypaper.com/sc/pets/search">pets</a></li>
		<li><a href="http://exchange.charlestoncitypaper.com/sc/billboard-services/search">services</a></li>
		<li><a href="http://citypapertickets.com">tickets</a></li>

	</ul>
 
 
</div>

<script>
	new Foundation.LoginRequiredComponent("thintop");
</script>


 


<div id="logoarea" class="GlobalHeader BlogPostFeedbackFile ">
 

      
        <div class="searchbuttonswrapper">
          <div id="searchbuttons">
            <div class="upperbuttons">
              <div class="searchcriteria">
                <a id="SearchButtonsToday" href="http://www.charlestoncitypaper.com/charleston/EventSearch?narrowByDate=Today" title="What's happening today">What's happening today</a><a id="SearchButtonsThisweek"  href="http://www.charlestoncitypaper.com/charleston/thisweek/page" title="What's happening this week">What's happening this week</a><a id="SearchButtonsStaffPicks"  href="http://www.charlestoncitypaper.com/charleston/EventSearch?feature=Staff Pick" title="Staff Picks">Staff Picks</a>
              </div><a id="SearchButtonsEventCalendar"  href="http://www.charlestoncitypaper.com/charleston/EventSearch" title="Complete calendar listings">Calendar Listings</a>
            </div>
            <div class="lowerbuttons">
              <a id="SearchButtonsFindLiveMusic" href="http://www.charlestoncitypaper.com/gyrobase/EventSearch?eventSection=1067887&eventCategory=1069927" title="Find live music">Find Live Music</a> <a id="SearchButtonsFindRestaurants"  href="http://www.charlestoncitypaper.com/charleston/LocationSearch?locationSection=1063747" title="Find restaurants">Find Restaurants</a>
            </div>
          </div>
        </div>
        
        
        
        
        
    		<div id="promotionsgroup" class="promotionlinks">

  		  
         
          

        
        
  		  <a href="http://slowfood.citypapertickets.com/events/41172987/second-annual-slow-food-charleston-snail-awards" target="_self">The Snail Awards recognize the best in local Slow Food</a>
  		  
          <br />
			

		  
		  
		
         
          

        
        
  		  <a href="http://charleston.strangertickets.com/" target="_self">Get tickets to Charleston&#39;s biggest events</a>
  		  
          <br />
			

		  
		  
		
         
          

        
        
  		  <a href="http://www.citypapertickets.com/events/41139914/igoddess-fair" target="_self">Get inspired at the iGoddess Fair April 15</a>
  		  

		  
		  
		
			</div>
		  
        
        
        <div class="logo">
          <a style="display:block;width:228px;height:71px;" href="http://www.charlestoncitypaper.com/"><img src="http://www.charlestoncitypaper.com/images/home/logo.gif" width="228" height="71" border="0" alt="Charleston City Paper" title="Charleston City Paper"/></a>
        </div>
        

 
 
</div>





<div id="NavigationHorizontal" class="GlobalHeader BlogPostFeedbackFile ">

  



  

  
  
        <ul id="mainNav">
      
      

      

      
      
      

      <li class="first" id="NavItem_FoodDrink">
        <a href="http://www.charlestoncitypaper.com/charleston/cuisine/Section?oid=1072085" class="subnav_link" id="SNAVL_FoodDrink" target="_self">Food+Drink</a>
      </li>
      

    
      

      

      
      
      

      <li class="navCurrent" id="NavItem_MusicClubs">
        <a href="http://www.charlestoncitypaper.com/charleston/music/Section?oid=1072086" class="subnav_link" id="SNAVL_MusicClubs" target="_self">Music+Clubs</a>
      </li>
      

    
      

      

      
      
      

      <li class="" id="NavItem_NewsOpinion">
        <a href="http://www.charlestoncitypaper.com/charleston/news/Section?oid=1072081" class="subnav_link" id="SNAVL_NewsOpinion" target="_self">News+Opinion</a>
      </li>
      

    
      

      

      
      
      

      <li class="" id="NavItem_ArtsMovies">
        <a href="http://www.charlestoncitypaper.com/charleston/arts/Section?oid=1072083" class="subnav_link" id="SNAVL_ArtsMovies" target="_self">Arts+Movies</a>
      </li>
      

    
      

      

      
      
      

      <li class="last" id="NavItem_CalendarScene">
        <a href="http://www.charlestoncitypaper.com/charleston/calendar/Section?oid=1072082" class="subnav_link" id="SNAVL_CalendarScene" target="_self">Calendar+Scene</a>
      </li>
      

    
        </ul>
      


    
    


    
    
       
        <h3 class="hidden">Browse News+Opinion</h3>
        <ul class="subnav_content" id="SNAV_NewsOpinion" style="display:none;">
         <li class="subnav_left">


        
        
             <ul id="subnav_headlines-trackme" class="subnav_headlines">
            

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/brett-bursey-has-been-organizing-for-more-than-four-decades/Content?oid=7634238">Brett Bursey has been organizing for more than four decades<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/an-organizer-of-the-charleston-womens-march-describes-her-first-foray-into-large-scale-demonstrations/Content?oid=7634437">An organizer of the Charleston Women's March describes her first foray into large-scale demonstrations<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/whatre-you-scared-of/Content?oid=7635149">What're you scared of?<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/advice-on-organizing-from-black-lives-matter-charlestons-muhiyidin-dbaha/Content?oid=7634440">Advice on organizing from Black Lives Matter Charleston's Muhiyidin d'Baha<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/charlestons-next-big-march-is-one-for-science/Content?oid=7634620">Charleston's next big march is one for science<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/avoiding-the-transgender-mistakes-of-the-queen-city/Content?oid=7635139">Avoiding the transgender mistakes of the Queen City<img src="/images/home/new.gif"></a>
           </li>

          
        
             <li id="navigationmorelink">
             <a href="http://www.charlestoncitypaper.com/gyrobase/ArticleArchives?section=oid:1072081">{ more }</a>
             </li>
          </ul>
          

        </li>
        <li class="subnav_right">
        <ul id="subnav_fixed-trackme" class="subnav_fixed">

      
      
      
      

      <li class="blogItem">
        <a href="http://www.charlestoncitypaper.com/blogs/TheBattery/" target="_self">The Battery</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/commentarchives" target="_self">Recent Comments</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/blotter/Content?category=1072145" target="_self">Blotter</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/SubmitALetter/Page" target="_self">Submit a letter to the editor</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/NewsTips/Page" target="_self">Submit a news tip</a>
      </li>

      
        </ul> </li></ul> <!-- check 5 - Submit a news tip - 98 -->
      


    
       
        <h3 class="hidden">Browse Calendar+Scene</h3>
        <ul class="subnav_content" id="SNAV_CalendarScene" style="display:none;">
         <li class="subnav_left">


        
        
             <ul id="subnav_headlines-trackme" class="subnav_headlines">
            

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/seersucker/archives/2017/04/12/king-streets-sartorial-staple-m-dumas-and-sons-celebrates-its-100-anniversary">King Street’s sartorial staple M. Dumas and Sons celebrates its 100th anniversary<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/freeloaders-spring-fling/Content?oid=7613948">Freeloaders: Spring fling</a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/weekend-roundup-off-to-the-races/Content?oid=7565040">Weekend Roundup: Off to the races</a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/freeloaders-fresh-and-free-ky/Content?oid=7480085">Freeloaders: Fresh and free-ky</a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/seersucker/archives/2017/04/03/hampden-clothing-celebrates-10-years-with-a-party-this-thursday">Hampden Clothing celebrates 10 years with a party this Thursday</a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/weekend-roundup-get-over-it/Content?oid=7426350">Weekend Roundup: Get over it</a>
           </li>

          
        
             <li id="navigationmorelink">
             <a href="http://www.charlestoncitypaper.com/gyrobase/ArticleArchives?section=oid:1072082">{ more }</a>
             </li>
          </ul>
          

        </li>
        <li class="subnav_right">
        <ul id="subnav_fixed-trackme" class="subnav_fixed">

      
      
      
      

      <li class="blogItem">
        <a href="http://www.charlestoncitypaper.com/blogs/seersucker" target="_self">Seersucker & Stilettos</a>
      </li>

      


    
       
      
      
      

      <li class="blogItem">
        <a href="http://www.charlestoncitypaper.com/blogs/chsdeals" target="_self">CP Perks</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/thisweek/page" target="_self">Coming up this week</a>
      </li>

      


    
       
      
      
      

      <li class="searchItem">
        <a href="http://www.charlestoncitypaper.com/charleston/EventSearch?narrowByDate=Today&eventSection=1069890" target="_self">Search events</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/beachguide" target="_self">Beach Guide</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://citypapertickets.com" target="_blank">Buy Tickets</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/events/addevent" target="_self">Submit an event</a>
      </li>

      
        </ul> </li></ul> <!-- check 12 - Submit an event - 10 -->
      


    
       
        <h3 class="hidden">Browse Arts+Movies</h3>
        <ul class="subnav_content" id="SNAV_ArtsMovies" style="display:none;">
         <li class="subnav_left">


        
        
             <ul id="subnav_headlines-trackme" class="subnav_headlines">
            

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/CultureShock/archives/2017/04/12/on-sale-now-mike-birbiglia-at-the-gaillard-sept-9">Buy tickets now to see Mike Birbiglia at the Gaillard on Sept. 9<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/cultivate-sc-holds-workshops-combining-science-lessons-art-instruction-and-happy-hour/Content?oid=7634800">Cultivate SC holds workshops combining science lessons, art instruction, and happy hour<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/this-year-columbias-indie-grits-celebrates-latinx-culture-with-visiones/Content?oid=7634805">This year Columbia's Indie Grits celebrates Latinx culture with <i>Visiones</i><img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/pointatv-bridges-the-gap-between-digital-signage-and-video-streaming/Content?oid=7634999">Pointa.TV bridges the gap between digital signage and video streaming<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/HolyCinema/archives/2017/04/11/confessions-of-a-southern-charm-newbie-influencer-by-birth">Confessions of a <i>Southern Charm</i> Newbie: Influencer by Birth</a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/Spoletobuzz/archives/2017/04/11/spoleto-tunes-up-with-six-figure-steinway-grand-piano-unveils-its-poster-and-honors-stephen-colberts-in-laws">Spoleto tunes up with six-figure Steinway grand piano, unveils its poster, and honors Stephen Colbert's in-laws</a>
           </li>

          
        
             <li id="navigationmorelink">
             <a href="http://www.charlestoncitypaper.com/gyrobase/ArticleArchives?section=oid:1072083">{ more }</a>
             </li>
          </ul>
          

        </li>
        <li class="subnav_right">
        <ul id="subnav_fixed-trackme" class="subnav_fixed">

      
      
      
      

      <li class="blogItem">
        <a href="http://www.charlestoncitypaper.com/blogs/cultureshock" target="_self">Culture Shock</a>
      </li>

      


    
       
      
      
      

      <li class="blogItem">
        <a href="http://www.charlestoncitypaper.com/blogs/holycinema" target="_self">Holy Cinema</a>
      </li>

      


    
       
      
      
      

      <li class="blogItem">
        <a href="http://www.charlestoncitypaper.com/blogs/spoletobuzz" target="_self">Spoleto Buzz</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/fallarts" target="_self">Fall Arts Issue</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?category=1072155" target="_self">Film Reviews</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/MovieTimes" target="_self">In Theaters Now</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/MovieTimes?narrowByDate=Today" target="_self">Movie Times</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/spoleto" target="_self">Spoleto 2016</a>
      </li>

      
        </ul> </li></ul> <!-- check 20 - Spoleto 2016 - 99 -->
      


    
       
        <h3 class="hidden">Browse Food+Drink</h3>
        <ul class="subnav_content" id="SNAV_FoodDrink" style="display:none;">
         <li class="subnav_left">


        
        
             <ul id="subnav_headlines-trackme" class="subnav_headlines">
            

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/Eat/archives/2017/04/12/meathouse-butcher-shop-business-is-for-sale">Meathouse Butcher Shop business is for sale<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/Eat/archives/2017/04/12/nicks-original-bbq-forced-to-close-king-street-location">Nick's Original BBQ forced to close King Street location<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/charlotte-park-is-giving-back-to-area-charities-one-dessert-at-a-time/Content?oid=7634808">Charlotte Park is giving back to area charities one dessert at a time<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/antonia-m-krenza-executive-chef-at-old-village-post-house-inn/Content?oid=7634811">Antonia M. Krenza, Executive Chef at Old Village Post House Inn<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/Eat/archives/2017/04/11/momo-gastrotruck-will-bring-bison-meat-hot-dogs-to-streets-in-may">MOMO Gastrotruck will bring bison meat hot dogs to streets in May</a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/Eat/archives/2017/04/10/giant-pizza-slice-seller-benny-ravellos-opens-on-king-street-this-week">Giant pizza slice seller Benny Ravello's opens on King Street this week</a>
           </li>

          
        
             <li id="navigationmorelink">
             <a href="http://www.charlestoncitypaper.com/gyrobase/ArticleArchives?section=oid:1072085">{ more }</a>
             </li>
          </ul>
          

        </li>
        <li class="subnav_right">
        <ul id="subnav_fixed-trackme" class="subnav_fixed">

      
      
      
      

      <li class="blogItem">
        <a href="http://www.charlestoncitypaper.com/blogs/eat" target="_self">Eat</a>
      </li>

      


    
       
      
      
      

      <li class="blogItem">
        <a href="http://www.charlestoncitypaper.com/blogs/BiteMe/" target="_self">Bite Me</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/dish" target="_self">DISH dining guide</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/dirt/Category?oid=3628746" target="_self">DIRT local food guide</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?category=1072160" target="_self">Restaurant Reviews</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/swig-bar-guide/Category?oid=1072162" target="_self">SWIG bar guide</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/EventSearch?eventSection=1069891" target="_self">Cuisine Calendar</a>
      </li>

      


    
       
      
      
      

      <li class="searchItem">
        <a href="http://www.charlestoncitypaper.com/charleston/LocationSearch?locationSection=1063747&locationCategory=&diningFeature=&neighborhood=&keywords=&sa=go" target="_self">Find a restaurant</a>
      </li>

      
        </ul> </li></ul> <!-- check 28 - Find a restaurant - 97 -->
      


    
       
        <h3 class="hidden">Browse Music+Clubs</h3>
        <ul class="subnav_content" id="SNAV_MusicClubs" style="display:none;">
         <li class="subnav_left">


        
        
             <ul id="subnav_headlines-trackme" class="subnav_headlines">
            

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/12/review-is-sofar-sounds-overhyped-or-nah">REVIEW: Is SoFar Sounds overhyped or nah?<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/here-are-this-years-record-store-day-highlights/Content?oid=7634983">Here are this year's Record Store Day highlights<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/charleston/charlestons-terraphonics-blend-global-and-local-sounds-on-debut-lp/Content?oid=7634986">Charleston's Terraphonics blend global and local sounds on debut LP<img src="/images/home/new.gif"></a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/11/put-these-8-southern-music-festivals-on-your-radar">Put these 8 Southern music festivals on your radar</a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/10/dr-john-headlines-first-festival-at-bowmans-yonder-field">Dr. John headlines first festival at Bowman's Yonder Field</a>
           </li>

          
        

            
            
            

           <li class="subnavHeadlines last">
             <a href="http://www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/07/saturday-community-to-celebrate-the-life-of-musician-and-cofcs-communications-museum-curator-rick-zender">Saturday: Community to celebrate the life of musician and CofC's Communications Museum curator, Rick Zender</a>
           </li>

          
        
             <li id="navigationmorelink">
             <a href="http://www.charlestoncitypaper.com/gyrobase/ArticleArchives?section=oid:1072086">{ more }</a>
             </li>
          </ul>
          

        </li>
        <li class="subnav_right">
        <ul id="subnav_fixed-trackme" class="subnav_fixed">

      
      
      
      

      <li class="blogItem">
        <a href="http://www.charlestoncitypaper.com/blogs/feedbackfile" target="_self">Feedback File</a>
      </li>

      


    
       
      
      
      

      <li class="searchItem">
        <a href="http://www.charlestoncitypaper.com/charleston/EventSearch?eventSection=1067887&eventCategory=1069927" target="_self">Find live music</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/LocationSearch?locationCategory=1067911" target="_self">Music venues</a>
      </li>

      


    
       
      
      
      

      <li class="">
        <a href="http://www.charlestoncitypaper.com/charleston/Page?id=submitmusiclisting&what=event" target="_self">Submit a music event</a>
      </li>

      
        </ul> </li></ul> <!-- check 32 - Submit a music event - 6 -->
      


    

    <script type="text/javascript">
      var panellinks = $$('.subnav_link');
      panellinks.each(function(fl) {
        var panel_id = 'SNAV_'+fl.id.split('_')[1];
        var link_w = fl.getWidth();
        new FloatingPanel(fl,panel_id,{
          rightOffset:'-' + link_w,
          topOffset:'44',
          effects: 'off',
          closeDelay:'0',
          allowDefault: true,
          beforeOpen: function() {
            fl.addClassName('hover');
            Element.up(fl).addClassName('hover');
          },
          beforeClose: function() {
            fl.removeClassName('hover');
            Element.up(fl).removeClassName('hover');
          }
        });
      });
    </script>
  

</div> <!-- end navigation -->



<div class="GlobalHeader BlogPostFeedbackFile " id="PencilBillboardSuperLeaderboardAd" style="width:970px;margin:0 auto 5px;">

<div id='div-gpt-ad-billboard-inside'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-billboard-inside'); });
</script>

</div>
</div>

 









  <!-- end gridHeader --></div>

  <div id="gridMain">
  
    <div id="gridFrame">
      <div id="gridSpanningHeader" class="clearfix">
        


  <div id="BlogHeader" class="SpanningHeader BlogPostFeedbackFile ">
    <div class="blogHeader clearfix" id="blogHeaderfeedbackfile">
      <h1><a href="http://www.charlestoncitypaper.com/blogs/FeedbackFile/">Feedback File</a></h1>
    </div>
  </div>


      <!-- end gridSpanningHeader --></div>

      <div id="gridColumnContainer" class="clearfix">
        <div id="gridMainColumn">
          









  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  

  <div id="BlogsBlogPost" class="MainColumn BlogPostFeedbackFile  topicView topic_local-bands">

    

    













    
    
    
    
  
    
      
      
        <h2 class="blogDate">Wednesday, April 12, 2017</h2>
      
    
      
      <div class="blogPost topic-local-bands topic-local-musicians topic-scene">

    <h3 class="postTitle" id="a7632691">    
      
      
      
        REVIEW: Is SoFar Sounds overhyped or nah?
      
      
      
    </h3>
    
    
      <h3 class="subheadline">It isn’t chic to use a DIY ethic — it’s utilitarian to use a DIY ethic</h3>
    

    <h4 class="postedBy">
      Posted 
      
        
        by <a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?author=6147989">Heath Ellison</a>
      
      on <span class="postTime">Wed, Apr 12, 2017</span> at <span class="postTime">11:15 AM</span>
    </h4>
    
    
    
    
    <div class="postBody">
      
      
      
      
           
      
      
      
      
      
        
        <div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/charleston/imager/u/original/7645236/screen_shot_2017-04-12_at_10.46.30_am.png" class="zoomable" rel="contentImg_gal-7632691" title="FALINE, headed by Jenna Ave-Lallemant, performed at Charleston&#39;s first SoFar Sounds event. - BRAVE BABY&#39;S INSTAGRAM">                  <img src="https://media2.fdncms.com/charleston/imager/u/blog/7645236/screen_shot_2017-04-12_at_10.46.30_am.png?cb=1492010137" width="250" height="225" alt="FALINE, headed by Jenna Ave-Lallemant, performed at Charleston&#39;s first SoFar Sounds event. - BRAVE BABY&#39;S INSTAGRAM" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Brave Baby's Instagram                                          </li>                                                                                                                            <li class="imageCaption">                      FALINE, headed by Jenna Ave-Lallemant, performed at Charleston's first SoFar Sounds event.                    </li>                                                                                                </ul>                                                       </div>It’s easy to get cynical about SoFar Sounds. Reading their website, it feels like they’re purposefully channeling the most obnoxious tendencies of music fans — namely an elitist obsession with things that are secretive. <br>
<br>
In case you hadn't heard of it, SoFar Sounds is a global network of artists and fans that helps to neatly organize BYOB house shows, keeping the location and performing artists a secret until one day before the event. The SoFar website claims it's a better way to discover live music, "if you can get in." While Charleston has had plenty of diverse options on the house show front for a long time now (more on that in a later piece), Charleston got its first SoFar taste on the evening of Fri. April 7. <br>
<br>
After attending last weekend, a lot of my pessimism washed away. It featured great performances from FALINE, who started the night off with some laid-back jangly indie rock, before Mechanical River, otherwise known as Joel Hamilton, took the stage. Hamilton quickly became a crowd favorite thanks to his wonderful and profound lyrics on songs like “Pomelos” and “The Swamp.” Brave Baby wrapped up the show by trying their hardest to stay low-key to fit the SoFar standards. It didn’t happen. They brought a danceable energy that felt out of place for a room full of people sitting down, and even performed a new song titled “Mothership.” More importantly, they lived up to their reputation as one of Charleston’s best.<br>
<br>
The night’s event took place at the Lawton Miles Studio in Wagener Terrace, which made for a great venue. The section that was open for the show felt like a small aircraft hangar. <br>
<br>
Even that online rhetoric about exclusivity was addressed by local SoFar chapter founder Owen Brown. When asked about it, he stated that he believes when a band announces they’re doing a show, their fans will show up. With the SoFar model of secrecy, people don’t know who’s playing, so they only go for the music and pay more attention to the artist. As a music discovery tool, it’s not a bad practice. Over 100 people were on the roster. Plus, I don’t think I would have discovered Joel Hamilton, otherwise, and he’s quickly become a new favorite. <br>
<br>
One attendee, who asked not to be named, said that he believes the SoFar setup is more for the musicians than a traditional venue. <br>
<br>
I do still have some lingering skepticism about SoFar’s band selection process and its influence on the local music scene, specifically how some attendees and volunteers compared what SoFar was doing to a grassroots movement. A pretty solid argument can be made that a grassroots happening can’t be aided by an national organization. That’s not to say the folks at the Charleston SoFar chapter have any malicious intent. The people involved with the event and the attendants all seemed very passionate about helping out local music. <br>
<br>
There’s also something inherently worrisome about SoFar’s ability to masquerade as something as independent as a house show. Turning a living room into a stage is such a powerful DIY statement. It’s a rejection of the establishment so deep that even traditional venues are being questioned. And secrecy wasn’t done to be hip. It was done because there was no money to advertise. It isn’t chic to use a DIY ethic — it’s utilitarian to use a DIY ethic.<br>
<br>
Mostly, the trouble with SoFar lies with SoFar as an organization. It’s still hard to get over the painfully self-righteous claim on their website that they’re “bringing the magic back to live music.” But, overall SoFar’s pretty benign, as long as the local scene doesn’t become too dependent on it. And overcoming that is pretty simple. Just don’t believe the hype.<br>
<br>
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    
      <span class="postCategory bottomTopics CategoryFeedbackFile">
        Topics: <a href="http://www.charlestoncitypaper.com/FeedbackFile/archives/local-bands/">Local Bands</a>, <a href="http://www.charlestoncitypaper.com/FeedbackFile/archives/local-musicians/">Local Musicians</a>, <a href="http://www.charlestoncitypaper.com/FeedbackFile/archives/scene/">Scene</a>
      </span>
    
    

    
    
      
      <p class="tags">
        Tags: <a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?tag=SoFar%20Sounds" rel="tag">SoFar Sounds</a>, <a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?tag=FALINE" rel="tag">FALINE</a>, <a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?tag=Brave%20Baby" rel="tag">Brave Baby</a>, <a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?tag=Mechanical%20River" rel="tag">Mechanical River</a>, <a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?contentFeature=4593280" rel="tag">Image</a>
      </p>
    
    
    



<div id="TweetLikeBlock">

	
    
	

	



	<iframe allowtransparency="true" frameborder="0" scrolling="no"
	src="http://platform.twitter.com/widgets/tweet_button.html?url=http%3A//www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/12/review-is-sofar-sounds-overhyped-or-nah&via=chasCityPaper&count=horizontal&text=REVIEW%3A%20Is%20SoFar%20Sounds%20overhyped%20or%20nah%3F"
        style="width:100px; height:23px;"></iframe>

	<iframe src="http://www.facebook.com/plugins/like.php?href=http%3A//www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/12/review-is-sofar-sounds-overhyped-or-nah&amp;layout=button_count&amp;show_faces=true&amp;width=150&amp;action=like&amp;font=verdana&amp;colorscheme=light" scrolling="no" frameborder="0" allowTransparency="true" style="margin-top:0px;margin-left:4px;border:none; overflow:hidden; width:90px; height:23px"></iframe>
      	
</div> 



  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>












  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  






  
  

  <div id="BlogsPreviousNext" class="MainColumn BlogPostFeedbackFile ">
    <div class="prevNext">
      <a href="http://www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/11/put-these-8-southern-music-festivals-on-your-radar" class="prev" rel="prev">&laquo;&nbsp;Put these 8 Southern music festival&hellip;</a>
    </div>
  </div>


















  










<!-- BEGIN TABOOLA -->
<hr />
<div style="width:655px;padding:0 10px 0 0;"><div id='taboola-bottom-main-column'></div></div>
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({mode:'autosized-generated-2r', container:'taboola-bottom-main-column', placement:'bottom-main-column'});
</script>
<!-- // END TABOOLA -->




  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="BlogComments" class="MainColumn BlogPostFeedbackFile CommentsComponent ">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
        
        <div id="BlogComments_commentContent" class="commentContent">
          
        </div>
        

        
          <div class="bottomOptionBar clearfix">
            
              <div style="float:left;">
      <div style="float:left;margin:4px 0; padding:4px 6px;">Subscribe to this thread:</div>
      <div style="position:relative;float:left">
      <div class="commentSubscribeLink">
        <a class="toggleActivator saveAction" id="doSubscribe" href="javascript://Subscribe">By Email</a>
      </div>
      <div class="togglePanel" data-toolsoid="7632691" data-toolsajaxmacro="commentSubscribe" style="display:none">
        <div class="toggleArrowBorder"></div>
        <div class="toggleArrow"></div>
        <a href="javascript://close" class="togglePanelClose"><img src="/foundation/images/icons/cross.png" width="14" height="14"></a>
        <div class="loading">Subscribing&hellip;</div>
        <div class="ajaxUpdater" style="display:none;"></div>
      </div>
      </div>
      <div class="commentRSSLink"><a href="/charleston/Rss.xml?id=comments&amp;oid=7632691" class="feedLink" title="Subscribe to this story's comments" target="_blank">With RSS</a></div>
      </div>
            
            
          </div>          
          
        <hr />

        

        
          

          <form id="BlogCommentsPostCommentForm" method="post" class="userCommentForm validateForm" data-validate="login" data-validate-login-options="{&quot;feelingShy&quot;:false}">
            <input type="hidden" name="commentType" value="comment" />
            <input type="hidden" name="oid" value="7632691" />
            <input type="hidden" name="source" value="desktop">

            
            

            <label for="comment" class="hidden">Comment</label>
            
              <h4 class="commentFormAddHeader"><a name="readerComments">Add a comment</a></h4>
            

            
            
            

            <div class="errorDisplay" style="display:none">
              <ol></ol>
            </div>
            <dl class="formElements clearfix">
            
              <dd><textarea name="comment" style="height:112px;overflow:hidden;" tabindex="1" class="expandableBox required" id="comment" data-validate="required"></textarea></dd>
            </dl>

            

            

            <input type="checkbox" name="subscribe" id="BlogComments_commentSubscribe" value="yes"> <label for="BlogComments_commentSubscribe" style="margin-right:24px;">Subscribe to this thread</label>
            
            

            <p class="commentFormSubmit">
              <input type="submit" name="commentSubmit" tabindex="2" value="Post Comment" id="commentSubmit" />
            </p>

          </form>
          <script>
            jQuery("textarea.expandableBox").autoBoxResize();
          </script>
        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  


        <!-- end gridMainColumn --></div>

        <div id="gridMainSidebar1">
          
        <!-- end MainSidebar1 --></div>
  
     <!-- end gridColumnContainer --></div>
    <!-- end gridFrame --></div>

 <div id="gridRightColumn">
 
    <div id="gridSpanningIsland">
      <div id="Home_MR1" class="SpanningIsland BlogPostFeedbackFile ">




<script type="text/javascript">

GA_googleFillSlot("Music-Clubs_MR1");

</script>

</div><div class="SpanningIsland BlogPostFeedbackFile " id="TopAd">  
<a href="http://exchange.charlestoncitypaper.com/">
<img alt="Classified Listings" title="Classified Listings" src="http://www.charlestoncitypaper.com/images/buttons/classifiedsbadge.gif" border="0"></a>

<!-- PUT THIS TAG IN DESIRED LOCATION OF SLOT Top_Ads -->


<script type="text/javascript">
  GA_googleFillSlot("Top_Ads");
</script>


<!-- END OF TAG FOR SLOT Top_Ads --> 


</div><div id="Home_MR2" class="SpanningIsland BlogPostFeedbackFile ">  




<script type="text/javascript">

GA_googleFillSlot("Music-Clubs_MR2");

</script>

</div>

<div id="RecentCommentsBlock" class="SpanningIsland BlogPostFeedbackFile  EdContent">
 
	<div class="RecentCommentsBar">
		<span class="morecomments"><a href="http://www.charlestoncitypaper.com/charleston/commentarchives">{ more }</a></span>
		<span class="morecommentsimage"><a class="EdContentBarImageLink" href="http://www.charlestoncitypaper.com/charleston/commentarchives"><img src="/images/home/recentcomments.gif" border="0" alt="Recent Comments"/></a></span>

	</div>
	<div class="EdContentPad">

		<ul class="MoreComments">
			
             
					<li class="commentwoo"><a href="http://www.charlestoncitypaper.com/charleston/an-organizer-of-the-charleston-womens-march-describes-her-first-foray-into-large-scale-demonstrations/Content?oid=7634437">An organizer of the Charleston Women's March describes her first foray into large-scale demonstrations</a>1 comment</li>
			
             
					<li class="commentwoo"><a href="http://www.charlestoncitypaper.com/HolyCinema/archives/2017/04/11/confessions-of-a-southern-charm-newbie-influencer-by-birth">Confessions of a <i>Southern Charm</i> Newbie: Influencer by Birth</a>8 comments</li>
			
             
					<li class="commentwoo"><a href="http://www.charlestoncitypaper.com/charleston/avoiding-the-transgender-mistakes-of-the-queen-city/Content?oid=7635139">Avoiding the transgender mistakes of the Queen City</a>3 comments</li>
			
             
					<li class="commentwoo"><a href="http://www.charlestoncitypaper.com/Eat/archives/2017/04/10/fast-and-french-joins-growing-national-trend-announces-no-tipping-policy">Fast and French joins growing national trend, eliminates tipping</a>1 comment</li>
			
             
					<li class="commentwoo"><a href="http://www.charlestoncitypaper.com/HolyCinema/archives/2017/04/04/confessions-of-a-southern-charm-newbie-season-4-premiere">Confessions of a <i>Southern Charm</i> Newbie: Season 4 Premiere</a>3 comments</li>
			
		</ul>
	</div>

</div>

<div id="Home_MR3" class="SpanningIsland BlogPostFeedbackFile ">  




<script type="text/javascript">

GA_googleFillSlot("Music-Clubs_MR3");

</script>

</div>








    
    


<div id="ReaderReviewsBlock" class="SpanningIsland BlogPostFeedbackFile  EdContent">
 
 
          <div class="ReaderReviewsBar">
          <span class="morecomments"><a href="http://www.charlestoncitypaper.com/gyrobase/commentarchives?feature=Locations">{ more }</a></span>
            <span class="morecommentsimage"><a  href="http://www.charlestoncitypaper.com/gyrobase/commentarchives?feature=Locations"><img src="/images/home/readerreviews.gif" border="0" alt="Reader Reviews"/></a></span>
            
          </div>
          <div class="EdContentPad">
            <ul class="RecentReviews">



<li>
   
<span class="miniheadline"><a href="http://www.charlestoncitypaper.com/charleston/the-mezz/Location?oid=4069245">The Mezz</a></span>


<div class="starsContainer tiny">
    <div class="goldStarContainer" style="left:0px;">
    </div>
    <div class="blankStarContainer">
      <div class="blankStarContainerSub">
        <div class="singleStar" style="left:0;"></div>
        <div class="singleStar" style="left:11px;"></div>
        <div class="singleStar" style="left:22px;"></div>
        <div class="singleStar" style="left:33px;"></div>
        <div class="singleStar" style="left:44px;"></div>
      </div>
    </div>
  </div>


      
        <span class="smallinfo"> I will miss this place.</span>
      
      
      
       <span class="postedby"> -<a href="http://www.charlestoncitypaper.com/charleston/Profile?oid=oid%3A7631434">Akilah Edwards</a></span>
      
</li>



<li>
   
<span class="miniheadline"><a href="http://www.charlestoncitypaper.com/charleston/crossfit-integrity/Location?oid=2355275">Crossfit Integrity</a></span>


<div class="starsContainer tiny">
    <div class="goldStarContainer" style="left:0px;">
    </div>
    <div class="blankStarContainer">
      <div class="blankStarContainerSub">
        <div class="singleStar" style="left:0;"></div>
        <div class="singleStar" style="left:11px;"></div>
        <div class="singleStar" style="left:22px;"></div>
        <div class="singleStar" style="left:33px;"></div>
        <div class="singleStar" style="left:44px;"></div>
      </div>
    </div>
  </div>


      
      <span class="smallinfo">  Wondering about the above review. I've been a member of Integrity since 2011. The warm&hellip;</span>
      
      
      
       <span class="postedby"> -<a href="http://www.charlestoncitypaper.com/charleston/Profile?oid=oid%3A7499942">Carman Dickson</a></span>
      
</li>



<li>
   
<span class="miniheadline"><a href="http://www.charlestoncitypaper.com/charleston/pages-okra-grill/Location?oid=1133900">Page's Okra Grill</a></span>


<div class="starsContainer tiny">
    <div class="goldStarContainer" style="left:0px;">
    </div>
    <div class="blankStarContainer">
      <div class="blankStarContainerSub">
        <div class="singleStar" style="left:0;"></div>
        <div class="singleStar" style="left:11px;"></div>
        <div class="singleStar" style="left:22px;"></div>
        <div class="singleStar" style="left:33px;"></div>
        <div class="singleStar" style="left:44px;"></div>
      </div>
    </div>
  </div>


      
      <span class="smallinfo">  One of the best sandwiches I've ever had. Charleston or elsewhere.<br> <br> The PBT is&hellip;</span>
      
      
      
       <span class="postedby"> -<a href="http://www.charlestoncitypaper.com/charleston/Profile?oid=oid%3A5467797">Kevin Brunson</a></span>
      
</li>



<li>
   
<span class="miniheadline"><a href="http://www.charlestoncitypaper.com/charleston/evan-guthrie-law-firm/Location?oid=4201349">Evan Guthrie Law Firm</a></span>


<div class="starsContainer tiny">
    <div class="goldStarContainer" style="left:0px;">
    </div>
    <div class="blankStarContainer">
      <div class="blankStarContainerSub">
        <div class="singleStar" style="left:0;"></div>
        <div class="singleStar" style="left:11px;"></div>
        <div class="singleStar" style="left:22px;"></div>
        <div class="singleStar" style="left:33px;"></div>
        <div class="singleStar" style="left:44px;"></div>
      </div>
    </div>
  </div>


      
        <span class="smallinfo"> I recommend Evan Guthrie Law Firm.</span>
      
      
      
       <span class="postedby"> -<a href="http://www.charlestoncitypaper.com/charleston/Profile?oid=oid%3A7334492">Carlton 1</a></span>
      
</li>



<li>
   
<span class="miniheadline"><a href="http://www.charlestoncitypaper.com/charleston/elite-dance-international-studio-and-apparel/Location?oid=2591656">Elite Dance International Studio and Apparel</a></span>


<div class="starsContainer tiny">
    <div class="goldStarContainer" style="left:0px;">
    </div>
    <div class="blankStarContainer">
      <div class="blankStarContainerSub">
        <div class="singleStar" style="left:0;"></div>
        <div class="singleStar" style="left:11px;"></div>
        <div class="singleStar" style="left:22px;"></div>
        <div class="singleStar" style="left:33px;"></div>
        <div class="singleStar" style="left:44px;"></div>
      </div>
    </div>
  </div>


      
      <span class="smallinfo">  An amazing group of people! Great for group classes, private lessons, & social nights! Highly&hellip;</span>
      
      
      
       <span class="postedby"> -<a href="http://www.charlestoncitypaper.com/charleston/Profile?oid=oid%3A3662765">EliteDanceCHS</a></span>
      
</li>



</ul>

</div>
 
</div>

<div id="Home_MR4" class="SpanningIsland BlogPostFeedbackFile clear ">  




<script type="text/javascript">

GA_googleFillSlot("Music-Clubs_MR4");

</script>

</div>





<div class="clear"></div>

<div id="MostViewedStories" class="SpanningIsland BlogPostFeedbackFile EdContent ">
  <div class="MostViewedBar"><img src="http://www.charlestoncitypaper.com/images/home/mostviewed.gif" alt="Most Viewed"></div> 

  
  <div class="clear"></div>
  
  <div class="readerCommentsBody">
  <div class="EdContentPad">
    <ul>
      
        <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.charlestoncitypaper.com/charleston/here-are-this-years-record-store-day-highlights/Content?oid=7634983">Here are this year's Record Store Day highlights</a>
    </h4>
    
      <h5 class="subhead">
        Needle Points
      </h5>
    
  </li>
        
              
        <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.charlestoncitypaper.com/charleston/charlestons-terraphonics-blend-global-and-local-sounds-on-debut-lp/Content?oid=7634986">Charleston's Terraphonics blend global and local sounds on debut LP</a>
    </h4>
    
      <h5 class="subhead">
        World Record
      </h5>
    
  </li>
        
              
        <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/10/dr-john-headlines-first-festival-at-bowmans-yonder-field">Dr. John headlines first festival at Bowman's Yonder Field</a>
    </h4>
    
      <h5 class="subhead">
        Bowman Bound is Bowman bound
      </h5>
    
  </li>
        
              
        <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/11/put-these-8-southern-music-festivals-on-your-radar">Put these 8 Southern music festivals on your radar</a>
    </h4>
    
      <h5 class="subhead">
        Shows on the Road
      </h5>
    
  </li>
        
              
        <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.charlestoncitypaper.com/FeedbackFile/archives/2017/04/12/review-is-sofar-sounds-overhyped-or-nah">REVIEW: Is SoFar Sounds overhyped or nah?</a>
    </h4>
    
      <h5 class="subhead">
        It isn’t chic to use a DIY ethic — it’s utilitarian to use a DIY ethic
      </h5>
    
  </li>
        
              
    </ul>
    </div>
  </div>
  

  

</div>

<div class="clear"></div>

<script type="text/javascript">
  GA_googleFillSlot("Trace_News");
</script>
    <!-- end gridSpanningIsland --></div>

    <div id="gridMainSidebar2">
      
    <!-- end gridMainSidebar2 --></div>

    <div id="gridAdSidebar">
      
    <!-- end gridAdSidebar --></div>
    
    <div id="gridBottomIsland">
      
    <!-- end gridBottomIsland --></div>
    
 </div><!-- end gridRightColumn -->    

    <!-- Footer -->
    <div id="gridFooter">
      

 

    <div id="FooterNavigation" class="GlobalFooter BlogPostFeedbackFile ">


  
	<ul class="footernavblock">
  
		<li class="footernavblocklabel"><a href="http://www.charlestoncitypaper.com/charleston/cuisine/Section?oid=1072085">Food+Drink</a></li> 
  
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/LocationSearch?locationSection=1063747&locationCategory=&diningFeature=&neighborhood=&keywords=&sa=go">Find a restaurant</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?category=1072160">Restaurant reviews</a></li>
		<li class="footernavblocklinks"><a href="/dish">DISH dining guide</a></li>
		<li class="footernavblocklinks"><a href="/swig">Swig bar guide</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/gyrobase/EventSearch?eventSection=1069891">Cuisine calendar</a></li>

	</ul>
	 
	
	<ul class="footernavblock">
  
		<li class="footernavblocklabel"><a href="http://www.charlestoncitypaper.com/charleston/music/Section?oid=1072086">Music+Clubs</a></li> 
  
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/EventSearch?narrowByDate=Today&eventSection=1067887&ongoing=Timely%2FLimited%20Run">Who's playing tonight</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/EventSearch?eventSection=1067887&eventCategory=1069927">Search live music</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?tag=Live%20Reviews">Live reviews</a></li>
		
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/Page?id=submitmusiclisting&what=event">Submit a listing</a></li>

	</ul>
	
	<ul class="footernavblock">
  
		<li class="footernavblocklabel"><a href="http://www.charlestoncitypaper.com/charleston/news/Section?oid=1072081">News+Opinion</a></li> 
  
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/blotter/Content?category=1072145">Blotter</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/blogs/TheBattery/">The Battery</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/blogs/haireofthedog/">Haire of the dog</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/NewsTips/Page">Submit a news tip</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/news/Section?oid=1072081">Columns</a></li>

	</ul>
	
	<ul class="footernavblock">
  
		<li class="footernavblocklabel"><a href="http://www.charlestoncitypaper.com/charleston/arts/Section?oid=1072083">Arts+Movies</a></li> 
  
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?category=1072155">Film reviews</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/MovieTimes?narrowByDate=Today">Movie times</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?category=1072153">Live theater</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?category=1072152">Visual arts</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/MoviesinthePark/Page">Movies in the Park</a></li>


	</ul>
	
	<ul class="footernavblock">
  
		<li class="footernavblocklabel"><a href="http://www.charlestoncitypaper.com/charleston/calendar/Section?oid=1072082">Calendar+Scene</a></li> 
  
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/EventSearch?narrowByDate=Today&feature=Staff%20Pick">Cool stuff to do today</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/ArticleArchives?tag=Scene">The Scene</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/charleston/EventSearch">Search events</a></li>
		<li class="footernavblocklinks"><a href="http://posting.charlestoncitypaper.com/charleston/Page?id=AddAListing&what=event">Submit an event</a></li>
		<li class="footernavblocklinks"><a href="http://www.charlestoncitypaper.com/blogs/seersucker">Seersucker & Stilettos</a></li>

	</ul>
	
	<ul class="footernavblock" style="margin-right:0px;"> 
  
		<li class="footernavblocklabel"><a href="http://exchange.charlestoncitypaper.com/">Classifieds</a></li> 
  
		<li class="footernavblocklinks"><a href="http://exchange.charlestoncitypaper.com/charleston/jobs/search">Jobs</a></li>
		<li class="footernavblocklinks"><a href="http://exchange.charlestoncitypaper.com/charleston/automotive-boats/search">Cars</a></li>
		<li class="footernavblocklinks"><a href="http://exchange.charlestoncitypaper.com/charleston/real-estate-for-sale/search">Homes</a></li>
		<li class="footernavblocklinks"><a href="http://exchange.charlestoncitypaper.com/charleston/pets-for-sale/search/">Pets</a></li>
		<li class="footernavblocklinks"><a href="http://exchange.charlestoncitypaper.com/charleston/billboard-services/search/">Services</a></li>
	</ul> 
	
<div style="clear:both;"></div>
	
		<div id="footerleaderboard">

    
      

      <script type="text/javascript">
        GA_googleFillSlot("Footer_Leaderboard-Music");
      </script>
    

</div>

<div style="clear:both;"></div>
	
<div id="footerofficiallinks">
<a href="mailto:webmaster@charlestoncitypaper.com">Problems with the site?</a> | <a href="http://www.charlestoncitypaper.com/charleston/ContactUs/Page">Contact us</a> | <a href="http://www.charlestoncitypaper.com/charleston/WhereToFindCopiesOfTheCityPaper/Page">Where to find copies</a> | <a href="http://www.charlestoncitypaper.com/charleston/PrivacyStatement/Page">Privacy statement</a> | <a href="http://www.charlestoncitypaper.com/charleston/TermsofUse/Page">Terms of use</a> | <b><a style="color:#df780e;" href="http://www.charlestoncitypaper.com/charleston/bestof">Best of Charleston</a></b> | <b><a style="color:#8eb123;" href="http://www.charlestoncitypaper.com/charleston/Advertising/Page">Advertising Info</a></b></div>
	


	
	
<div style="clear:both;"></div>

    </div>

<div style="clear:both;"></div>



<div id="footerCopyright">
  <p>
    Powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a> &nbsp;
    &copy; Copyright 2017, 
    <a href="http://www.charlestoncitypaper.com/">Charleston City Paper</a>
    &nbsp;&nbsp;<a href="http://www.charlestoncitypaper.com/charleston/Syndication"><img src="/images/rss.gif" alt="RSS" width="36" height="14" border="0" align="top"></a>
  </p>
</div>





<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-2043889-2', 'auto');

var dimension1Value = 'musicclubs';
var dimension2Value = 'FeedbackFile';
ga('set', 'dimension1', dimension1Value); // section
ga('set', 'dimension2', dimension2Value); // category

ga('send', 'pageview');

</script>

<script type="text/javascript">
  function recordOutboundLink(link, category, action) {
    _gat._getTrackerByName()._trackEvent(category, action);
    setTimeout('document.location = "' + link.href + '"', 100);
  }
ga('require', 'linker');
ga('linker:autoLink', ['secondstreetapp.com']);
</script>

<!-- Start Quantcast tag -->
<script type="text/javascript">
_qoptions={
qacct:"p-7apeS9pNVYMQo"
};
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
<noscript>
<img src="http://pixel.quantserve.com/pixel/p-7apeS9pNVYMQo.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</noscript>

<script type="text/javascript">
_qoptions={
qacct:"p-62vCixfRK5kes"
};
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
<noscript>
<img src="http://pixel.quantserve.com/pixel/p-62vCixfRK5kes.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</noscript>

<script type="text/javascript">
_qoptions={
qacct:"p-a4LDpi_DEopn-"
};
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
<noscript>
<img src="http://pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</noscript>



<script src="http://static.getclicky.com/js" type="text/javascript"></script>
<script type="text/javascript">clicky.init(183746);</script>
<noscript><img alt="Clicky" width="1" height="1" src="http://in.getclicky.com/183746ns.gif" /></noscript>


<!-- Begin comScore Tag -->
<script>
    document.write(unescape("%3Cscript src='" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js' %3E%3C/script%3E"));
</script>

<script>
  COMSCORE.beacon({
    c1:2,
    c2:6035631,
    c3:"",
    c4:"",
    c5:"",
    c6:"",
    c15:""
  });
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035631&c3=&c4=&c5=&c6=&c15=&cj=1" />
</noscript>
<!-- End comScore Tag -->


<!-- Chartbeat Tag -->














<script type='text/javascript'>
    var _sf_async_config = _sf_async_config || {};
    /** CONFIGURATION START **/
    _sf_async_config.uid = 62058;
    _sf_async_config.domain = 'charlestoncitypaper.com';
    _sf_async_config.useCanonical = true;
    _sf_async_config.sections = 'Music+Clubs'; 
    _sf_async_config.authors = 'Heath Ellison'; 
    /** CONFIGURATION END **/
    (function() {
        function loadChartbeat() {
            window._sf_endpt = (new Date()).getTime();
            var e = document.createElement('script');
            e.setAttribute('language', 'javascript');
            e.setAttribute('type', 'text/javascript');
            e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
            document.body.appendChild(e);
        }
        var oldonload = window.onload;
        window.onload = (typeof window.onload != 'function') ?
            loadChartbeat : function() {
                oldonload();
                loadChartbeat();
            };
    })();
</script>


<!-- END Chartbeat -->

<!--HELLOBAR-->
<script src="//my.hellobar.com/63c5ddba2ec2863901a5c3008f02d25f56836f16.js" type="text/javascript" charset="utf-8" async="async"></script>

<!--END Hellobar -->

<!-- Async Ads -->
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1034489/Homepage_Pencil', [[970, 90], [970, 250], [975, 50]], 'div-gpt-ad-pencil-homepage').addService(googletag.pubads());
    googletag.defineSlot('/1034489/Music_Pencil', [[970, 90], [970, 250], [975, 50]], 'div-gpt-ad-pencil-music').addService(googletag.pubads());
    googletag.defineSlot('/1034489/Pencil_Arts', [[970, 90], [970, 250], [975, 50]], 'div-gpt-ad-pencil-arts').addService(googletag.pubads());
    googletag.defineSlot('/1034489/Pencil_Calendar', [[970, 90], [970, 250], [975, 50]], 'div-gpt-ad-pencil-calendar').addService(googletag.pubads());
    googletag.defineSlot('/1034489/Pencil_Food', [[970, 90], [970, 250], [975, 50]], 'div-gpt-ad-pencil-food').addService(googletag.pubads());
    googletag.defineSlot('/1034489/Pencil_News', [[970, 90], [970, 250], [975, 50]], 'div-gpt-ad-pencil-news').addService(googletag.pubads());
    googletag.defineSlot('/1034489/Pencil_Other', [[970, 90], [970, 250], [975, 50]], 'div-gpt-ad-pencil-other').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<!-- // Async Ads -->


  <img src="/foundation/images/icons/pixel.gif?oid=7632691" alt="" />

<!-- BEGIN TABOOLA -->
<script type="text/javascript">
   window._taboola = window._taboola || [];
   _taboola.push({article:'auto'}); 
</script>
<script type="text/javascript" src="http://cdn.taboolasyndication.com/libtrc/alternative-charlestoncitypaper/loader.js"></script>
<!-- // END TABOOLA -->
    <!-- end gridFooter --></div>

  <!-- end gridMain --></div>
<!-- end gridClamp --></div>

<!-- Closer -->
<div id="gridCloser">
  
</div><!-- end gridCloser -->

    </body>
</html>
  


